Bash | Alt255 Blog

December 30, 2017

OSX Bash Upgrade

Notes on getting bash completion to work on OSX and upgrade bash along the way. Using brew, install bash-completion: $ brew install bash-completion Update .bashrc to include: if [ -f /usr/local/etc/bash_completion ] && . /usr/local/etc/bash_completion If you receive errors like this: bash: compopt: command not found, your version of bash is likely outdated. Check the version using bash --version. compopt apparently requires version 4.0 or above. To upgrade bash using brew: ... Read more